Jump to content


Photo

Read Xml attributes in installshield script


  • Please log in to reply
2 replies to this topic

#1 rameshr

rameshr
  • Members
  • 3 posts

Posted 26 September 2005 - 11:48

I'm using InstallShield 10.5 version. I'v created one setup file that gets input like database name, username ,password etc from Configuration.xml file.

I'v used the function "OpenFile" to read the data's from xml configuration file, but i'm unable to assign this xml data's to the install shield properties like IS_SQLSERVER_SERVER, IS_SQLSERVER_USERNAME, etc in the installshield script window (.rul) and it shows that "IS_SQLSERVER_SERVER undeclared identifier".

I used "System Search" but it was not satisfied my needs. Is there any other way to assign the xml attributes value to the installshield in-built properties or user defined properties?. I want to achieve this implementation only through Installshield script. For past one week I'm struggling to get the proper output, please provide me a solution to overcome this problem.

Thanks

Ramesh.R smile.gif

#2 antyagi

antyagi
  • Full Members
  • 121 posts

Posted 28 September 2005 - 15:54

looks like you are doing some thing like,
IS_SQLSERVER_SERVER = "some_value"; ohmy.gif

This is not right, you should use MsiSetProperty function, instead.

  ankur tyagi

#3 rameshr

rameshr
  • Members
  • 3 posts

Posted 28 September 2005 - 17:12

Hi antyagi,

Thanks for your solution. smile.gif . I will try to assign the values by using MsiSetProperty function.

Thanks
Ramesh.R