Jump to content


Photo

ISDEV : fatal error -7159


  • Please log in to reply
12 replies to this topic

#1 garyflet

garyflet
  • Full Members
  • 36 posts

Posted 11 December 2013 - 20:34

We've been building installs with InstallShield 2011 for a year or two using a command line and IsCmdBld on Windows Server 2008.  Though nothing I know of has changed, suddenly this morning we have a problem.  Now we get the error message:

 

ISDEV : fatal error -7159: The product license has expired or has not yet been initialized.
Product Configuration 1\Release 1 - 1 error(s), 0 warning(s)
 
But InstallShield builds without error from the IDE.  Why would IsCmdBld suddenly fail?  As far as I know there is no license we have to renew.
 

Here is the command line:

%ProgramFiles%\InstallShield\2011\System\IsCmdBld -p IsCmdBld -p %BASE_DIR%\InstallShield\Setup.ism -y %NEW_VER%

 

Thanks for any suggestions..



#2 Stefan Krueger

Stefan Krueger

    InstallSite.org

  • Administrators
  • 13,259 posts

Posted 12 December 2013 - 21:09

That's strange. Either contact Flexera support or try de-activating (from the About dialog) and then re-activating InstallShield.



#3 surendba

surendba
  • Full Members
  • 4 posts

Posted 12 April 2014 - 03:16

We have the similar issue.

The same IsCmdBld.exe works ok if I log into the Windows 2008 R2 Server and run manually.

But fails with the below error if I call it from outside the server.

I put this command in a batch file and this batch file gets called from a tool outside the server using WinRM.

The outside tool use PowerShell script to call this batch file running in our build server.

 

The batch file has this line 

"C:\Program Files (x86)\InstallShield\2013\System\ISCmdBld.exe" -p E:\InstallShieldProjects\CommSeeClientInstaller\R340\CommSee.ism -c COMP -l PATH_TO_CLIENT_FILES=E:\CommSee\R340\bin\Client -y 34.0.0.0 -z ProductName=CommSee_34.0.0.0 -a Test5 -r 34.0.0.0 -e N -x > out.txt

 

Error I see when running this batch file from an outside tool which calls this batch file using WindRM is

InstallShield ®
Release Builder
Copyright © 2013 Flexera Software LLC.
 
All Rights Reserved.
 
Build started at Apr 12 2014 11:28 AM
Building Release: 34.0.0.0
 
ISDEV : fatal error -7159: The product license has expired or has not yet been initialized.
Test5\34.0.0.0 - 1 error(s), 0 warning(s)
 
Build finished at Apr 12 2014 11:28 AM


#4 Glytzhkof

Glytzhkof
  • Moderators
  • 1,446 posts

Posted 12 April 2014 - 11:32

I was under the impression that Installshield had switched to yearly license fees, but maybe that is just in the last edition?

 

Check if this "solution" works for you: http://community.fle...license-expired . I am not keen on running services with a user account, but it may be sufficient for your purpose. Make sure you lock down the account as much as possible though. Essentially the link describes how to run the build process with a user account and not a windows service since the user account has network access.


Edited by Glytzhkof, 12 April 2014 - 12:00.

Regards
-Stein Åsmul

#5 Stefan Krueger

Stefan Krueger

    InstallSite.org

  • Administrators
  • 13,259 posts

Posted 12 April 2014 - 18:08

Stein: InstallShield licenses are perpertual, they only need to be re-activated yearly, i.e. the license will be validated yearly. Maintenance plans (which entitle to free updates and support) however need to be renewed yearly.

 

surenda: The command line builder from the full InstallShield installation (with the IDE) probably expects a user to be logged in (because the license is only valid for one user). For an automated build on the server try the Stand Alone Build tool, which is a sperate (free) download from the Product and License Center. It may work better in this scenario.



#6 Glytzhkof

Glytzhkof
  • Moderators
  • 1,446 posts

Posted 13 April 2014 - 16:12

Thanks for clearing that up Stefan. Perhaps the wikipedia article should be updated, it says $599/yr for Installshield: http://en.wikipedia....lation_software


Regards
-Stein Åsmul

#7 surendba

surendba
  • Full Members
  • 4 posts

Posted 13 April 2014 - 23:38

Thanks Stefan and Glytzhkof for the advice. 

I will try to use the Stand alone build tool as you've suggested.

Will let you know that outcome

 

Regards

Suresh



#8 Stefan Krueger

Stefan Krueger

    InstallSite.org

  • Administrators
  • 13,259 posts

Posted 16 April 2014 - 16:19

Stein, such a Wikipedia article will essentially always be outdated and doesn't take into accound different editions, maintenance plans, and pricing differences by region; nor does it account for diifferent feature sets. So I don't want to spend time updating it.



#9 Glytzhkof

Glytzhkof
  • Moderators
  • 1,446 posts

Posted 21 April 2014 - 16:19

True - though the current content there looks almost like it is intentionally wrong. I know I give up software for good if the license expires. I guess it is Installshield's own responsibility to deal with such erroneous information.


Regards
-Stein Åsmul

#10 surendba

surendba
  • Full Members
  • 4 posts

Posted 06 June 2014 - 10:23

Hi,

Just an update on the License error issue : ISDEV : fatal error -7159: The product license has expired or has not yet been initialized.

 

This is the product our organisation bought  : InstallShield 2013 Premier + InstallShield Premier Silver Maintenance

This product includes  5 "InstallShield Standalone Builds" licenses as well.

 

I installed the 'Standalone Build" in the same build server where I am running the IS 2013 Premier and Remotely called the Standalone build's ISCmdBld.exe usig WinRM.

Now the MSI Project compiles successfully!

 

Thanks

Suresh



#11 Sebbo11

Sebbo11
  • Full Members
  • 7 posts

Posted 04 July 2014 - 06:22

I just had the same error and the simple solution was to press the "Update" button in the About box. The license is then reactivated and after restarting InstallShield everything was fine.

 

Regards

Sebastian



#12 uday1kiran

uday1kiran
  • Full Members
  • 1 posts

Posted 26 July 2016 - 13:05

I tried all the above options...

In fact, there is no update button in About tab in 2014.

 

Any other suggestion for this problem...??



#13 Stefan Krueger

Stefan Krueger

    InstallSite.org

  • Administrators
  • 13,259 posts

Posted 29 July 2016 - 10:52

Contact support, they will be able to help you with activation errors.