Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Crystal Reports 9

2 replies to this topic


  • Full Members
  • 93 posts

Posted 03 February 2003 - 17:57

Has anyone tried to use the merge modules provided by Crystal Decisions for Crystal 9?  I've include them and they fail to install regardless of the dotNet framework being there.

Product Availability Developer
Invensys Process Systems

Using InstallShield Developer 7.04 - Basic Project


  • Members
  • 7 posts

Posted 05 June 2003 - 12:44

I did a lot of fiddling with the Crystal Reports 9 Merge Modules and this is how far I am:

I am using the following merge modules from Crystal Reports 9:

I am using "Install Shield for Windows Installer Version 1.02"

I entered the registration key of my Crystal Reports 9 license into the Custom Property [PIDKEY]
of the license.msm merge module
(i need to use the english version, the german license.msm doesnt has this property ???)

I added the 3 merge modules to my msi project.

I added the standard action "InstallExecute" right after the "BindImage" action
(this is necessary according to KB Q106852 from installshield knowledge base,
otherwise you will get a MSI Error: Internal Error 7263)

Now i run my setup and it fails with
MSI Error: Internal Error 7262!!!

I did some debugging and got the following output from MSI:
[464] MSI (s) (D0:A0): Doing action: ConfigureWebServices.A95D0BB4_0582_442D_B456_D295EAEB7628
[464] MSI (s) (D0:A0): Note: 1: 2762

So the Custom Action "ConfigureWebServices.A..." is causing this error
This Custom Action is located in the reportengine.msm merge module

I have no Idea how to solve this

Any suggestions?
I reportet this to CrystalDecicions, but no answer so far

Anyone else experienced this problem?

The setup was run on 2 different machines, one running Win2k SP3 and one WinXP SP1


  • Members
  • 16 posts

Posted 09 June 2003 - 15:31

i have taken all those steps as well and i'm still getting the "internal error 2763" message when i try to run the setup. why is developer riddled with bugs? if anyone can help out, it would be greatly appreciated.