Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

1334 and patches

1 reply to this topic


  • Members
  • 1 posts

Posted 24 February 2003 - 18:08


Anyone encountered this one... We have a lot apps out there that were installed using IS developer 7.02. I have updated to IS 7.04 (to avoid 1334 bug). I created a patch, there are no dynamically linked files, but I do get 1334 error when trying to update the original installs. To test this further I created exact same old install using 7.04, created a exact same patch and voila same update works now fine. But problem is that my clients have installed using old 7.02 based installs and there seems to be no way around the error 1334 - what is a point of patching if they have to uninstall and reinstall the old version first??? The weird thing is that my other application works fine updated with same combination of IS. If there were more info why error 1334 happens (I have read this forum regarding 1334 and tried/looked into everything suggested so far...), maybe I could figure out if there is something that is wrong with my install?  




  • Members
  • 15 posts

Posted 20 March 2003 - 17:28

Error 1334 (msi.chm from msi sdk 2.0)
The file '[2]' cannot be installed because the file cannot be found in cabinet file '[3]'. This could indicate a network error, an error reading from the CD-ROM, or a problem with this package.

So if you install your patch you trigger a reinstall.
with this different files are 'rewritten' (funny that unversioned files are only overwritten if they didn't change ...) and are searched for in the cab.

can you doublecheck if the mentioned file [2] is flagged to be part of a cab in file table?
can you doublecheck how msi wants to handle the file (see logfile with msiexec /p ... /Lv* <Logfilepath>)

After this it should be possible to do further steps.