Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Problem in redistributing the .Net Framework with

2 replies to this topic


  • Members
  • 4 posts

Posted 11 August 2005 - 11:41

I have a windows application developed using C# .net..i want to deploy the application using Installshield X. I m using the "SingleImage" option in the "build your release".

Now i would like to tell you some of the option which i have selected.

1- .Net Framework Location= Copy from source media
2- .Net Framework Version= .Net 1.1
3- Cmd Line to pass to Dotnetfx.exe = /q:a /c:"install /q"
4- Display .Net Option Dialog= Yes
5- .Net Build Configuration = Release

after setting many other selections i created a setup...
When the project is compiled and build...there are "1033dotnetfx.exe", "dotnetfx.exe" and "MySetup.exe".

The problem is that when i install the setup at a test machine where windows 2000 is installed. It displays the message box..would you like to install .Net Framework 1.1. If the i select yes it shows some description that it is opening the Dotnet msi file.
After that it installs the application.
but when i run the application it does not run.. and shows errors which lead me to the conclusion that Framework is not installed yet.

I want to install it automatically before application deployment..

Can anybody tell me How can i do that..?
Am i missing something serious..?

Please Help

Stefan Krueger

Stefan Krueger


  • Administrators
  • 13,269 posts

Posted 14 August 2005 - 10:47

Did you try without passing a custom command line to Dotnetfx.exe ?


  • Members
  • 4 posts

Posted 15 August 2005 - 06:23

Yeh i have tested it...but the same result.
Now i have left that version of Installshield and using Installshield 11 pro version. I am passing the same parameters... it is installing Framework successfully...