Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Upgrading IS603 projects: FeatureSetTarget

1 reply to this topic


  • Members
  • 12 posts

Posted 19 January 2002 - 05:26


We upgraded a perfectly working IS 603 project to IS 702 and are having problems using script-defined variables in our registry and destination folders ever since.

Any help would be greatly appreciated on these two issues:

1)  Where are the script-defined folders now? In IS 603, they used to be in the File Groups | Destination. In IS 702, best I can figure, you have to create a component, add files to the component and create the user-defined folder through the GUI in the bottom window.
Then through IS script, add FeatureSetTarget (MEDIA, <szCustomerFolder>, szAppPath) statement.

2) We use the same statements in our registry.  We created a registry component since you can no longer link a registry set to more than 1 file group (component) any longer. So we created a component of just registry entries and added them as subfeatures to every feature. In our registry, we used a script-defined variable <szAppPath> that was set in IS script with ComponentSetTarget (now FeatureSetTarget) but that no longer works.  A blank path is entered into the registry now.

I've tried IS support which I found to be very unhelpful on the first attempt.


  • Members
  • 12 posts

Posted 30 January 2002 - 16:21

Hey again,

Just in case anyone was interested..

We found out from experimentation that the FeatureSetTarget feature really doesn't do anything at all in IS702.

For migrating from IS 603 to IS 702, you have to do these things:

1) FeatureSetTarget doesn't do anything so remove it.
2) Create a property in PropertyManager for all the script defined variables that you used in IS 603 previously.
3) Use MsiSetTarget to set the value. For example:


4) Very important: The statement must be in OnFirstUIBefore. We had it in OnMoving (like the doc said) and it never worked.

Hopefully, this is helpful to anyone running into the same problems.