Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

visual debugger problem

3 replies to this topic


  • Full Members
  • 407 posts

Posted 13 May 2003 - 12:06


I'd like to run a normal setup (without debug file) on a target system as debug version.

To do this I have to
  • include the isdgb*.dll into the path (WINDIR)
  • run setup.exe with debug option

Then I found that -d can be used to define the path of setup.rul, but this doesn't work for me ...

All I can do is run setup.exe -da:\setup.dbg to define the path of the debug file.
Debugger is still asking for the rule file.
Can I give that information in the run statement too?
Or is it just a typo in the german help file ????
Gruß / regards

Taco Bell

Taco Bell

    IS6 Expert

  • Moderators
  • 1,281 posts

Posted 25 May 2003 - 11:56

You know I'm an IS6 user, but I'll say this anyways ...

It just wants the path to the debug information and not the actual file, so just run setup.exe -da:\

Also, the isdgb*.dll needs to be previously registered on the system.


Okay, this may have been the wrong advice for IS5 because I just looked at 6's help file and it said the following:

Runs setup in debug mode. The -d switch also includes a <pathonly> option for specifying the path of the Setup.dbg file (but not the filename, unlike previous versions of InstallShield Professional). For more information, refer to the Visual Debugger help file.

So try it anyways, or maybe it's the fact the DLL isn't registered. Well good luck then and sorry I couldn't be more helpful.

Edited by TacoBell00, 25 May 2003 - 12:01.

user posted image

Stefan Krueger

Stefan Krueger


  • Administrators
  • 13,269 posts

Posted 26 May 2003 - 10:00

I believe you can only specify the path to the .dbg file (not sure whéther with ot without file name) on the command line. BTW be sure you copy the .dbg file to the test machine.
When prompted you must browse to the .rul file, so it must be available either on the test machine, or via network.


  • Full Members
  • 407 posts

Posted 26 May 2003 - 16:05

Hello Stefan!

I'm afraid, it is as you say.
The online help is not that clear, but I found that you can just add the filename of the debug file to the debug flag.
You have to specify the rule file if it is not found at the path that is used inside the ide.

It was an attempt to run a debug session with as few user actions as possible ...
Gruß / regards