Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Missing files after installation

1 reply to this topic

Rob Scheepens

Rob Scheepens
  • Members
  • 2 posts

Posted 21 February 2005 - 13:21

Hello all,

I've got a strange behaviour of DevStudio 9.
(Note: I've migrated the project from InstallShield 6.5)

I've done the following:
I've added a new feature.
Then added a component to this feature.
This component consists of one directory that contains multiple subdirectories.

I see the following:
When I check the cab-file, all files are present (the newly added feature files).
Within the Organization - Setup types view, I can see the new feature is selected
When I check the logfile (*.ilg), the directory is present, but there are NO subdirectories/ files present.
Thus nothing is installed.

I have already tried the following:
Created a new Release. ( same result)
Made the new feature required for another feature (that was installed) no success).

Does anyone have an idea how to solve this problem???

Oh, I tried another thing: I've added the new component to another feature AND THEN IT WORKS??? So a workaround is available, but it isn't the way.


Rob Scheepens

Rob Scheepens
  • Members
  • 2 posts

Posted 22 February 2005 - 08:04

Hello again,

I've still been trying to solve my problem.
It seems that an added feature is not copied to the Targetdir.

My structure is:
- Main feature
- Sub feature 1
- Component 1.1
- Sub feature 2
- Component 2.1
- New feature
- New component

All features except the new one are processed correctly.
But when I add the 'New component' directly to the 'Main feature', then it works.....javascript:emoticon(';)')

I have tried to remove the 'Release package' (known issue encountered during the InstallShield DevStudio course), but still no difference.

Please help me with this annoying problem.

Kind regards,

Rob Scheepens