Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Setup failed to run installation (0x80040707)

4 replies to this topic


  • Members
  • 1 posts

Posted 18 October 2001 - 15:48

InstallShield Installation Error
This error has been found trying to install Siebel software as well as Great Plains Integration Manager 6.0. It is a bug in the InstallShield installation program so it could be encountered in any software installation that uses InstallShield. The error is documented below.
"Setup failed to run installation (0x80040707)"
During setup initialization, sometimes an error message 0x80040707 with no additional information is displayed. After that setup appears to continue, but is not fully initialized, resulting in various consequential problems.
There are other problems that can also cause an 0x80040707 error message, such as wrong DLL function prototypes or an illegal format specifier in Sprintf. The bug discussed in this article is unique in that it occurs during setup initialization, that is while the "Your Application Name Setup is preparing the InstallShield wizard ..." progress bar is displayed. At this time your install script is not yet running, so the error cannot be cause by an error in your script.
It is still obscure which conditions cause this problem. There is a discussion group for people affected by this error (under Special Topics -> DosExecPgm Error). If you are affected by this error, please collect as much information as possible, such as Windows version, language and service pack, network settings, regional settings, virus scanners, Internet Explorer, and other installed software packages, and post it to the group. Hopefully some scheme can be identified that helps to find the cause and fix the problem.
This is the IS 6.2 variant of the DosExecPgm problem that happened on IS 6.1. It still exists in IPSE 6.22.
InstallShield stated that this is an operating system issue. Additional information is available in the discussion group.


This may not be the only solution to this problem but it has worked on two machines that were having the problem. The following solution talks specifically about the “Common Desktop” entry but I found that our problem is related to the “Common Start Menu” entry.

The following is the solution received from InstallShield Support.

The information below shows how to fix this problem by modifying this system, this was determined by trial and error and is not documented by MS and involves updating the registry. Also, please note that this is not the only possible cause of this type of error, just the error that was occurring in this specific case.

To fix this problem open the "Regedt32.exe" registry editor (This is the NT 3.51 style editor) go to the registry under:

HKLM\\Software\Microsoft\Windows\Current Version\Explorer\Shell Folders

notice that the value of "Common Desktop" under this key is:

C:\WINNT\All Users\Desktop

this folder does not exist. However, changing this value directly will have NO EFFECT.

Next locate the key "User Shell Folders" under the same key as above. Add the following value as type REGSZ_EXPAND:

Common Desktop = %SystemRoot%\Profiles\All Users\Desktop

Note that this value MUST be of type REGSZ_EXPAND, this is why it is necessary to use the NT 3.51 style registry editor.

Then restart Windows and verify that the appropriate value under "Shell Folders" has been changed to a valid folder. 6.1x setups should then work properly.

Note that this could also be a problem if any of the following values under "User Shell Folders" are missing or invalid.:

Common Start Menu, Common Startup, Common Desktop, Common Programs

This is the registry entry I had to add to my registry:

HKLM\\Software\Microsoft\Windows\Current Version\Explorer\User Shell Folders\Common Start Menu


It has to be type REG_EXPAND_SZ that is why you have to use regedt32.exe. “regedit” does not allow you to add an entry of this type.

Stefan Krueger

Stefan Krueger


  • Administrators
  • 13,269 posts

Posted 18 October 2001 - 20:13

#Moderation Mode

Moved to DosExecPgm forum

Moved here


  • Members
  • 1 posts

Posted 24 November 2001 - 18:28

Recently bought Canon multipass F30 printer/scanner.
While using their CD installer I encountered the error
0x80040707 and I have now found that I am not alone
with this error number.
I have installed many programs on the computer so the
procedure has worked before.  I talked with a Canon
rep for 1.5 hours while she tried to help.
I provided 400 Mb hard drive space.  I used msconfig
and removed all running programs and virus protection.
I cleared the Windows Temp files.  I rebooted the
I use Windows 98, a Toshiba laptop with 300 Mhz
Pentium 2 and 64 Mb of RAM.

Have I a problem caused by the software installation
software provided by Canon?
Do I have a software problem with Windows 98?

Any help greatly appreciated.



  • Members
  • 1 posts

Posted 08 February 2002 - 21:09

I just had this same error occur.  I used this solution and was able to install my software (Dell Array Manager, eWorks.)

I discovered that this issue occurred with me because I use an NT Policy that redirects the Common Start Menu.  Consequently, the NT Policy deletes the Common Start Menu key every time a user logs in.

I hope this helps someone...

Stefan Krueger

Stefan Krueger


  • Administrators
  • 13,269 posts

Posted 07 July 2002 - 06:34

Posted on behalf of user boksw:

We have the same problem:
Setup failed to run installation (0x80040707)

My solution was:
e.g. install the setup under the administrator account.
This installation will be failed. I think because the policies on this account.

  • Log in with another account, rename the c:windowsprofilesadministrator in e.g. admin
  • log in with administrator, accept the first logon, yes an new c:windowsprofilesadministrator is created.

After this you can install the software.