Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Getting error 1647 while uninstalling with a suite project

1 reply to this topic


  • Full Members
  • 187 posts

Posted 13 October 2015 - 00:11



I am making a demo for a presentation for the future of my product installers.  It is centered around using Suite Installers to more easily make one unified installer.  I am creating my demo project and I can't get a package to uninstall.


The details:


I have 4 Basic MSI project outputs added as packages to the Suite Installer project.

These Basic MSI projects all have a setup.exe boot strapper and they are compressed into a single exe file.

I added them to the Suite project as EXE packages.


My issue is that I am getting error 1647 when I attempt to uninstall one of the packages.  The others I am not trying to test yet.

The target I am using is the exe output from the Basic Msi project.

The arguments that I am using are: /V"/uninstall {A0241C5B-A6DA-4640-9637-D0E757B495FF} /qn /lv "c:\temp\log.txt""


I added the logging to help figure out what is wrong.


The lines in the log that might be helpful are:

MSI (s) (38:44) [18:56:35:346]: Product: MyProduct - Update '{A0241C5B-A6DA-4640-9637-D0E757B495FF}' could not be removed. Error code 1647. Additional information is available in the log file c:\temp\log.txt.

MSI (s) (38:44) [18:56:35:346]: Windows Installer removed an update. Product Name: MyProduct. Product Version: Product Language: 1033. Manufacturer: MyCompany. Update Name: {A0241C5B-A6DA-4640-9637-D0E757B495FF}. Removal success or error status: 1647.

MSI (s) (38:44) [18:56:35:347]: Note: 1: 1708
MSI (s) (38:44) [18:56:35:347]: Product: MyProduct -- Installation failed.


The Basic MSI Project is authored as a major upgrade.

I also did some extensive patch testing recently but I ran a program to parse all the installed products and their related patches.  Nothing showed up for this product.


Any insight would be helpful and appreciated.




  • Full Members
  • 187 posts

Posted 13 October 2015 - 18:46

After some thought, I realized that the command I was trying to execute was not correct. 


The Suite project was attempting to execute the original installation exe again and pass uninstall arguments to the MSI file.  However the boot strapper started in install mode so the 2 commands are in conflict.


Once I switched the exe to be MsiExec rather than the original setup file, things worked ok on the command line.


The suite however did not work because the launcher did not elevate its privileges.  Does anyone know how to force the suite project to elevate when launched through add/remove programs?

On my releases view, I already have the setup.exe settings tab property "Required Execution Level" set to Administrator.

There is no other place I can modify the setup that I can find.