Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Serious Problem with Component Transfer

2 replies to this topic


  • Members
  • 3 posts

Posted 04 August 2003 - 13:06

Hi All,

I am facing some serious problem using InstallShield 7, while uninstalling setups created in InstallShield 6.03.

Setup created in IS7.01 and the un installation of IS6 setup is done with UninstallApplication built in function of IS7 (I have tried to uninstall IS6 setup with LaunchAppAndWait, DoInstall function with WAIT or LAAW_OPTION_WAIT option gives the same result). This works fine but when IS7 starts transferring components the setup is crashing. It is displaying error as “Error: 0”.

This occurs on Win98, Win98SE, WinME, Win2K, WinXP operating system.

I have added OnComponentError handler in the setup to trap the information about the error. ComponentErrorInfo returns ErrorInfo object. But the ErrorInfo.Feature object is not getting created, so it comes in the else part of if(IsObject(ErrorInfo.Feature))then construct. As per the help given on ComponentErrorInfo function, If the error is not associated with a particular component, or the component cannot be identified, this property is not set. There only one information box is displayed saying “Error: 0”. So further I used ComponentError function to retrieve more information about the error. ComponentError also returns the same information. Both the screen shots are attached herewith.

This error happens only when I try to uninstall the IS6 setup, if I comment the call to uninstall IS6 setup then IS7 setup installs component without error. One more thing we can’t recreate the IS6.03 setup in IS7, as the product is already shipped. The setup created in IS7 is next version of this product.

I have IS7.01 with Hotfix1 and Hotfix2 installed on my machine and I am using IS7 on Win2k machine.

I have checked the Help, KB articles, Pro 6 and 7 forum, InstallSite to find some solution. There is no documentation is available on “Error: 0”.

Please anybody from the forum give me some input to solve the problem?


  • Members
  • 5 posts

Posted 05 August 2003 - 21:29

I can only suggest the following: make sure the new install is completely independent of the old one, that is, make sure all GUIDs are regenerated (app and component GUIDs). Secondly, to uninstall the application, try using the LaunchAppEx function available from installsite at



  • Members
  • 3 posts

Posted 08 August 2003 - 06:17

Hi Ted,

Thanks for your reply. As per your suggestion I have checked the GUIDs of all components and setup is checked with both the setups and confirmed that these are different. I have tried the second suggestion about using LaunAppEx from InstallSite and it also gives the same problem.

But I have some important conclusions, which I would like to share. If IS6 and IS7 are installed on the same machine and builds are made on the same machine then it works perfectly. But IS6 and IS7 are installed on the different machine with exactly identical configurations then this bug is reproducible. Is there any compatibility issue with IS6 and IS7?

In my case the earlier build is released in the market and practically we could do nothing to that build. So new version of application need to uninstall old version of application from the target machine and install new version.

Any suggestions are highly appreciated.