Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Data1.cab has invalid digital signature. This may indicate that cabine

1 reply to this topic


  • Full Members
  • 77 posts

Posted 10 October 2014 - 14:01



Created a DVD package with Data1.cab for Main product release. This Data1.cab file was signed with a digital certificate. The certificate expired in June 2014.

Got new certificate. I am required to patch the previous main release. Signed the patch package (.msp) with new signature. Install the patch over main package. installation is successful.


Tried to modify the package to add a feature which we not installed when main product was installed. While modifying the package got above error.


Tried a lot including updating the root certificate from below link. Still does not work.




Anybody has clue ?


Thanks in advance for your suggestions.





Edited by Amarjeet, 10 October 2014 - 14:01.


  • Full Members
  • 187 posts

Posted 13 October 2014 - 15:49

Can you make sure the root CA that counter signed your certificate is installed on your system and that its properties are enabled to support Code Signing?


To do this, from the computer that shows this behavior, in a run dialog type "mmc".

This will bring up a blank Microsoft Management Console.

File->Add/Remove Snap in

In the list, add Certificates.  A short wizard will popup.  Select Computer account and local computer.

Confirm all the dialog boxes to get back to the MMC window.

Expand the tree view to view the Trusted Root Certification Authorities.

Locate your Root CA in the list and look at the properties.  If the root CA is not there, this is a cause of the problem.  If the CA is not enabled for the code signing purpose, this is the cause.


As for the latter, I don't know why a Root CA that sold you a certificate for Code Signing would not be enabled for Code Signing.  It is possible it got disabled somehow but this would worry me.  Try looking at a default Windows install to see if this is set up correctly out of the box.