Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Setup files not put into temporary folder

1 reply to this topic


  • Full Members
  • 1 posts

Posted 23 October 2008 - 22:56

I am running InstallShield 5.1. We have been using it to install each new version of our application and all has been fine until it was somewhat changed to handle the next version of the application. Note that our application in the past was built using Visual Studio 6 but our new version has been ported to Visual Stusion 2008 using the .NET framework 2.0. The problem is as follows:

I have a group of files (DLLs, etc.) that are needed during the installation process. They are in the Language Independent / OS Independent category and can be correctly seen when you view the Setup Files tab in InstallShield. When I try to install our product in XP or Vista, the setup files are not copied to the temporary folder as they are supposed to which means that when the installation needs them, they are not available.

Here is the odd thing. If I install a previous version of our product, as indicated above, it works fine. I then uninstall the previous version. Having done that, installing the new version of the application begins to work. It seems that installing the previous version triggers something. The only way I can get the new version to stop working again is to re-load the operating system.

I would appreciate any help anyone might have.

Stefan Krueger

Stefan Krueger


  • Administrators
  • 13,269 posts

Posted 31 October 2008 - 17:45

I'd suggest running ProcessMonitor to see whether there are any write failures, like permission issues with the temp folder.
Does your old version change the TEMP environment variable? I know that IS 5 has problems if the path to the TEMP folder is very long. Back in the time it used to be something like C:\Temp and that worked. Nowadays it sometimes is like C:\Documents and Settings\<User Name>\Local Settings\Temp

As a test, change the TEMP environment variable to a shorter path to see if that helps.