Jump to content

This is a ready-only archive of the InstallSite Forum. You cannot post any new content here. / Dies ist ein Archiv des InstallSite Forums. Hier können keine neuen Beiträge veröffentlicht werden.

Prerequisite install failure (sometimes)

2 replies to this topic


  • Full Members
  • 1 posts

Posted 29 June 2017 - 17:50

Hi I have a rather complex installer (basic msi) with multiple features and feature prerequisites (9 of them). The feature prerequisites run msi (or setup.exe) installers in quiet mode. The setup.exe ones are VC runtimes and the msi ones are my own packages (shared dependencies also used in other installers). Now most of the time the installation runs smoothly but repeating the install on the same clean snapshot of the same windows 7 pro VM) gives occasional random failure of a random prerequisite. That is to say sometime when I run the install it will indicate that a particular prerequisite failed - It isn't any one particular prerequisite that fails and seems as though it can be any one of them! I have had no option but to abort the install if this happens. If it fails then running the install a second time nearly always succeeds. The question is what is causing this and how can it be avoided, whether its a even windows installer bug etc.  I'm not sure if is specific to this VM or windows 7 (latest SP and up to date updates but also failing on several older snapshots with less up to date windows updates) in general or all windows versions. I have also tried a similar installer (for a different product) that also uses prerequisites but less of them and with this it also fails in a similar way but far less often. Leads me to think that any feature prerequisite has a small probability that it may randomly fail for no good reason. Another thing I have noticed is there is a very large variation in the amount of time taken to install all prerequisites and it is sometime fast but often long delays on one or more (as indicated by the status). I'm seeing this in about 1 in 20 (maybe more) installs so its incredibly tedious to reproduce. The only error shown in the log is error 1935.

I'm wondering if there is any further info I can gather that will help locate the cause or if there is a known issue here that can be worked around.


The user will see a message like "The installation of <prerequisite name> has failed. Setup will now exit."


I see something like this in a msi log file:

Error 1935. An error occurred during the installation of assembly 'NavSystems.Core.Teigha14a,version="",type="win32",publicKeyToken="dbf166d4daaa41f2",processorArchitecture="x86"'. Please refer to Help and Support for more information. HRESULT: 0x800736B3. assembly interface: IAssemblyCacheItem, function: Commit, component: {F68912B7-80FA-462F-A656-A2878DF28E67}

=== Logging stopped: 29/06/2017  17:43:11 ===
The error message is always Error: 1935 but the rest of the detail depends on which prerequisite fails.
The log for the main installer shows...
The installation of NavSystems - Core Teigha 14a Runtime Redistributable has failed. Setup will now exit.
Any thoughts?

Edited by bluespider, 29 June 2017 - 17:54.


  • Full Members
  • 187 posts

Posted 29 June 2017 - 20:24

My only thought would be to change your prq file to include MSI logging command line arguments for each or as many of your installers as possible.  It can tell you:

1. if the installer ran at all

2. If the installer encountered an error, was forced to roll back/abort, and what that error was.


If you make the logging changes to all your prq files, you can maximize the chances that you will catch the error.

Stefan Krueger

Stefan Krueger


  • Administrators
  • 13,269 posts

Posted 05 July 2017 - 08:36

When I read the first part of your post my first thought was: Did the prerequisite install really fail, or is it a timing issue (InstallShield checks the condition for success before the prerequisite installer has fully completed).

But since you always get error 1935 (assembly install failed) I don't really know what might be causing this.